VCP – Data Center Virtualization – Question 119

Exam 2V0-622 : VMware Certified Professional 6.5 – Data Center Virtualization

Upgrading vCenter Server with Microsoft SQL database fails with the following error message:
The DB User entered does not have the required permissions needed to install and configure vCenter Server with the selected DB. Please correct the following error(s): %s

What could cause this error?

A. incorrect ports open on SQL Server
B. incorrect database on the SQL server
C. incorrect compatibility mode on the SQL server
D. incorrect permission on SQL Server database

Correct Answer: C
Problem
The following error message appears: The DB User entered does not have the required permissions needed to install and configure vCenter Server with the selected DB. Please correct the following error(s): %s

Cause
The database version must be supported for vCenter Server. For SQL, even if the database is a supported version, if it is set to run in compatibility mode with an
unsupported version, this error occurs. For example, if SQL 2008 is set to run in SQL 2000 compatibility modem this error occurs.

Reference:
https://docs.vmware.com/en/VMware-vSphere/6.0/com.vmware.vsphere.upgrade.doc/GUID-5AA32F87-270C-4171-8896-41A607F8F997.html